Forex data is not updating in TC2000

Incident Report for TC2000

Resolved

This incident has been resolved.
Posted Oct 24, 2022 - 10:55 EDT

Investigating

We are currently investigating this issue.
Posted Oct 24, 2022 - 10:47 EDT
This incident affected: Market Data Feeds.