Problem with paper trading in TC2000

Incident Report for TC2000

Resolved

This incident has been resolved.
Posted May 06, 2026 - 12:26 EDT

Investigating

We are currently investigating an issue with paper trading in TC2000. We are looking into the issue and will have it resolved as soon as possible.
Posted May 06, 2026 - 09:50 EDT
This incident affected: Paper Trading (simulated).