Problem with calls to customer service

Incident Report for TC2000

Resolved

This issue has been resolved.
Posted Oct 20, 2025 - 14:14 EDT

Monitoring

It looks like issue has cleared up but we're continuing to monitor.
Posted Oct 20, 2025 - 11:33 EDT

Investigating

We're currently having an issue with our phone system related to the AWS issues today.

To contact TC2000 support, please email support@TC2000.com or go to the support chat page at https://www.tc2000.com/support/chat

To contact TC2000 Brokerage support, please email support@TC2000Brokerage.com or go to the support chat page at https://www.tc2000.com/support/chat
Posted Oct 20, 2025 - 10:14 EDT
This incident affected: Customer Service.