Problems logging into the TC2000 Web Platform and platforms for Mac and Mobile
Incident Report for TC2000
Resolved
This incident has been resolved.
Posted Jun 15, 2021 - 10:43 EDT
Investigating
We are currently experiencing a problem with customers logging into the TC2000 Web Platform and Platforms for Mac and Mobile. We will have this corrected as soon as possible.
Posted Jun 15, 2021 - 10:18 EDT
This incident affected: Software.