Historical Bid, Ask and Mid not plotting

Incident Report for TC2000

Resolved

This incident has been resolved.
Posted Jul 29, 2026 - 13:59 EDT

Investigating

We are currently working on an issue with historical Bid, Ask and Mid not plotting on the charts. We'll have this fixed as soon as possible.
Posted Jul 29, 2026 - 12:06 EDT
This incident affected: Market Data Feeds.