Problem canceling orders in TC2000

Incident Report for TC2000

Resolved

This incident has been resolved.
Posted Jun 13, 2022 - 12:46 EDT

Identified

TC2000 Brokerage Customers: We have identified the issue and are working to get it corrected. Until this issue is resolved, orders can be placed or managed through TWS https://www.interactivebrokers.com/en/index.php?f=16040&ns=T or client portal https://ndcdyn.interactivebrokers.com/sso/Login?partnerID=WTrade
Posted Jun 13, 2022 - 10:18 EDT

Investigating

Some TC2000 Brokerage customers are having issues modifying or canceling open orders. We are investigating this issue and will update as soon as we have more information.
Posted Jun 13, 2022 - 09:57 EDT
This incident affected: Brokerage Services.