Problems logging into TC2000 with Parallels and Web Platform
Incident Report for TC2000
Resolved
This incident has been resolved.
Posted Jun 09, 2022 - 12:18 EDT
Investigating
We're currently having an issue with the Parallels client and the Web Platform which is preventing customers from logging into TC2000. We are investigating this issue and will have it corrected as soon as possible.
Posted Jun 09, 2022 - 11:19 EDT
This incident affected: Software.