Problem logging into TC2000 via Parallels and sending/receiving TC2000 Support emails
Incident Report for TC2000
Resolved
These incidents have been resolved.
Posted Oct 18, 2022 - 10:20 EDT
Investigating
We are currently experiencing a problem with customers logging into TC2000 via Parallels. This is affecting customers accessing via Web Platform and Parallels on Mac and Mobile. We will have this corrected as soon as possible.

We are also experiencing an issue sending and receiving emails from Support@TC2000.com so replies will be delayed. We will get this corrected as soon as possible.
Posted Oct 18, 2022 - 09:12 EDT
This incident affected: Software.