Problems logging into TC2000
Incident Report for TC2000
Resolved
This incident has been resolved.
Posted Jan 30, 2024 - 13:03 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 30, 2024 - 12:10 EST
Investigating
We are currently investigating this issue. Brokerage clients can manage orders and positions through the client portal (https://www.tc2000.com/brokerage/accountportal) or Trader Workstation (https://www.interactivebrokers.com/en/index.php?f=16040&ns=T)
Posted Jan 30, 2024 - 12:08 EST
This incident affected: Software.