TC2000 is temporarily down
Incident Report for TC2000
Resolved
This incident has been resolved.
Posted Apr 26, 2020 - 17:43 EDT
Identified
We have identified the issue on our end and are working to get it corrected. We estimate everything returning to normal by 2pm ET and will provide an update if that changes.
Posted Apr 26, 2020 - 11:06 EDT
This incident affected: Software and Market Data Feeds.