Problems connection to TC2000 services

Incident Report for TC2000

Resolved

This incident has been resolved.
Posted Aug 07, 2025 - 13:32 EDT

Identified

We've identified the issue with our carrier and they are working to get it corrected.
Posted Aug 07, 2025 - 10:37 EDT

Investigating

We're aware of an internet issue outside of our network preventing some customers from logging in to TC2000. We are investigating this issue and will post an update when we have more information.
Posted Aug 07, 2025 - 09:41 EDT
This incident affected: Software.