Login delays with the TC2000 Web Platform
Incident Report for TC2000
Resolved
This incident has been resolved.
Posted Oct 21, 2020 - 11:34 EDT
Investigating
Customers accessing TC2000 via the Web Platform are experiencing delays in logging in. We are currently investigating this issue.
Posted Oct 21, 2020 - 11:18 EDT
This incident affected: Software.