TC2000 data is not streaming
Incident Report for TC2000
Resolved
This incident has been resolved.
Posted Jun 03, 2020 - 09:51 EDT
Investigating
We are currently investigating this issue.
Posted Jun 03, 2020 - 09:37 EDT
This incident affected: Market Data Feeds.