Problem logging into TC2000 via Parallels
Incident Report for TC2000
Resolved
This incident has been resolved.
Posted Jun 08, 2021 - 16:11 EDT
Investigating
We are currently experiencing a problem with customers logging into TC2000 via Parallels. This is affecting customers accessing via Web Platform and Parallels on Mac and Mobile. We will have this corrected as soon as possible.
Posted Jun 08, 2021 - 15:23 EDT
This incident affected: Software.