Dow Jones indexes are not updating
Incident Report for TC2000
Resolved
This incident has been resolved.
Posted May 28, 2020 - 16:21 EDT
Update
We are continuing to investigate this issue.
Posted May 28, 2020 - 14:57 EDT
Investigating
Dow Jones index data is not updating in real time. We are investigating this issue.
Posted May 28, 2020 - 14:06 EDT
This incident affected: Market Data Feeds.