Web Platform and Customer Service
Incident Report for TC2000
Resolved
This incident has been resolved.
Posted Oct 30, 2024 - 13:13 EDT
Investigating
We are currently having a network issue that is preventing customers from accessing the Web Platform and contacting support via chat or email.

We are working to get the problem corrected.

Brokerage clients who use Parallels can manage orders and positions through either of the following:
The client portal at https://www.tc2000.com/brokerage/accountportal.
Trader Workstation at https://www.interactivebrokers.com/en/index.php?f=16040&ns=T.
Posted Oct 30, 2024 - 08:15 EDT
This incident affected: Software and Customer Service.