Problem logging into TC2000 via Parallels
Incident Report for TC2000
Resolved
This incident has been resolved.
Posted Jun 09, 2021 - 12:49 EDT
Update
We're still investigating this issue and it is mainly affecting the Web Platform of TC2000. If you are a Windows user you install the Windows version of TC2000 at https://www.tc2000.com/download. If you are a Mac user you can install the Parallels Client for Mac at https://help.tc2000.com/m/31181/l/1220762-how-to-install-tc2000-anywhere-on-a-mac.
Posted Jun 09, 2021 - 10:55 EDT
Investigating
We are currently experiencing a problem with customers logging into TC2000 via Parallels. This is affecting customers accessing via Web Platform and Parallels on Mac and Mobile. We will have this corrected as soon as possible.
Posted Jun 09, 2021 - 09:42 EDT
This incident affected: Software.