Trouble logging into TC2000

Incident Report for TC2000

Resolved

This incident has been resolved.
Posted Nov 10, 2025 - 11:37 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 10, 2025 - 10:19 EST

Identified

The issue has been idetified and a fix is being implemented.
Posted Nov 10, 2025 - 10:11 EST

Investigating

We are currently investigating a network issue that is preventing some customers from logging in to TC2000 and are working to get it resolved.

Brokerage clients can manage orders and positions through either of the following:
The client portal at https://www.tc2000.com/brokerage/accountportal.
Trader Workstation at https://www.interactivebrokers.com/en/index.php?f=16040&ns=T
Posted Nov 10, 2025 - 09:43 EST
This incident affected: Software.