Customer service phone lines are down
Incident Report for TC2000
Resolved
This incident has been resolved.
Posted Apr 22, 2024 - 14:02 EDT
Monitoring
Our service provider is continuing to work on this issue.
Posted Apr 22, 2024 - 11:39 EDT
Investigating
Due to an issue with our phone provider the TC2000 Brokerage and TC2000 Software sales lines are currently down. You can email support@tc2000.com or support@tc2000Brokerage.com or you can start a live chat https://www.tc2000.com/support/chat with any questions or issues and our support agents will get back to you as quickly as possible. For brokerage questions you can also press 9 while on the brokerage line to leave a message. Our provider is currently working on correcting this issue and should hopefully have it resolved shortly.
Posted Apr 22, 2024 - 11:37 EDT
This incident affected: Customer Service.