Options data delayed in TC2000 this morning

Incident Report for TC2000

Resolved

This incident has been resolved.
Posted Nov 14, 2023 - 10:13 EST

Investigating

We are currently investigating this issue.
Posted Nov 14, 2023 - 10:08 EST
This incident affected: Market Data Feeds.