Problems logging into TC2000 via Parallels
Incident Report for TC2000
Resolved
This incident has been resolved.
Posted Mar 01, 2024 - 12:29 EST
Update
We are continuing to investigate this issue.
Posted Mar 01, 2024 - 10:45 EST
Update
We are continuing to investigate this issue.
Posted Mar 01, 2024 - 10:43 EST
Update
We are continuing to investigate this issue.
Posted Mar 01, 2024 - 10:42 EST
Update
We are continuing to investigate this issue.
Posted Mar 01, 2024 - 10:40 EST
Investigating
We are currently investigating the issue with the Parallels version.

The Windows desktop version is 100% operational and can be installed from https://www.tc2000.com/download.

Brokerage clients who use Parallels can manage orders and positions through either of the following:
The client portal at https://www.tc2000.com/brokerage/accountportal.
Trader Workstation at https://www.interactivebrokers.com/en/index.php?f=16040&ns=T.
Posted Mar 01, 2024 - 09:45 EST
This incident affected: Software.