Options data in TC2000 is running a few minutes behind
Incident Report for TC2000
Resolved
This incident has been resolved.
Posted Feb 10, 2021 - 12:40 EST
Investigating
We are currently investigating this issue and will have it corrected as soon as possible.
Posted Feb 10, 2021 - 10:51 EST
This incident affected: Market Data Feeds.