Version 7 download problem

Incident Report for TC2000

Resolved

This issue has been resolved.
Posted Oct 17, 2025 - 09:27 EDT

Investigating

We're currently having an issue with downloads/updates on version 7. Working to have this resolved as soon as possible.
Posted Oct 17, 2025 - 08:52 EDT
This incident affected: Software.