Paper trading in TC2000 is currently offline
Incident Report for TC2000
Resolved
This incident has been resolved.
Posted Feb 23, 2021 - 10:20 EST
Investigating
Paper trading in TC2000 is currently unavailable. We will have it back online as soon as possible.
Posted Feb 23, 2021 - 09:34 EST
This incident affected: Software.