Problem placing trades in TC2000 - TC2000 Brokerage
Incident Report for TC2000
Resolved
This incident has been resolved.
Posted Apr 14, 2021 - 11:58 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 14, 2021 - 11:17 EDT
Investigating
Investigating reports of clients being unable to place orders through the TC2000 Software. Until this issue is resolved orders can be placed or managed through TWS https://www.interactivebrokers.com/en/index.php?f=16040&ns=T or client portal https://ndcdyn.interactivebrokers.com/sso/Login?partnerID=WTrade If you need to close a position immediately you can do so over the phone by calling TC2000 Brokerage at 1-800-508-9150 or the IB trade desk directly at 203-618-4030
Posted Apr 14, 2021 - 09:56 EDT
This incident affected: Software and Brokerage Services.