Trading and account management are currently down for TC2000 Brokerage. We are working with the clearing firm to identify the problem.
Incident Report for TC2000
Resolved
This incident has been resolved.
Posted Dec 07, 2020 - 10:52 EST
Monitoring
We believe that trading and account management are fully operational. We are testing and monitoring all systems to be sure.
Posted Dec 07, 2020 - 10:11 EST
Investigating
We are currently investigating this issue.
Posted Dec 07, 2020 - 08:37 EST
This incident affected: Brokerage Services.