Problem logging into TC2000

Incident Report for TC2000

Resolved

This incident has been resolved.
Posted Oct 13, 2025 - 11:56 EDT

Identified

The issue has been identified and we are working to get it corrected.
Posted Oct 13, 2025 - 11:04 EDT

Investigating

Some customers are reporting problems with logging into TC2000.

We are currently investigating and will have it resolved as soon as possible.

Brokerage clients can manage orders and positions through either of the following:
The client portal at https://www.tc2000.com/brokerage/accountportal.
Trader Workstation at https://www.interactivebrokers.com/en/index.php?f=16040&ns=T
Posted Oct 13, 2025 - 09:31 EDT
This incident affected: Software.