Trading in TC2000 is currently unavailable
Incident Report for TC2000
Resolved
This incident has been resolved.
Posted Mar 05, 2021 - 22:18 EST
Identified
Our clearing firm (Interactive Brokers) is currently reporting an issue that is affecting the ability of clients, including clients of introducing brokers, to place orders through any platform. This includes TC2000, TWS and the Client Portal. Any orders placed during this time will be cancelled and result in a status of "Killed by Monitor" until this issue is resolved. We are monitoring this situation closely and will work with them to restore trading capabilities as quickly as possible.
Posted Mar 05, 2021 - 17:04 EST
This incident affected: Brokerage Services.