Widespread internet problem today.
Incident Report for TC2000
Resolved
This incident has been resolved.
Posted 3 months ago. Jun 30, 2018 - 07:38 EDT
Identified
Posted 3 months ago. Jun 29, 2018 - 14:38 EDT
Investigating
Comcast and Xfinity are having a widespread outage today which is affecting some customers accessing TC2000. The only information we have so far is that it is unclear what is causing the outage and when the service might be up and working again.
Posted 3 months ago. Jun 29, 2018 - 14:08 EDT
This incident affected: Software and Brokerage Services.