Stock & Option Positions Not Showing in Software
Incident Report for TC2000
Resolved
This incident has been resolved.
Posted 11 months ago. Nov 15, 2018 - 11:26 EST
Investigating
We are currently investigating this issue.
Posted 11 months ago. Nov 15, 2018 - 09:41 EST
This incident affected: Software, Brokerage Services, and Paper Trading (simulated).