U.S. markets are closed Wednesday, Dec 5th
Incident Report for TC2000
Resolved
This incident has been resolved.
Posted 6 months ago. Dec 04, 2018 - 22:11 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 6 months ago. Dec 04, 2018 - 22:10 EST
Investigating
U.S. markets will be closed Wednesday, Dec 5th for a national day of mourning to honor the late former President George H.W. Bush. TC2000 and TC2000 Brokerage customer service will be closed.
Posted 6 months ago. Dec 04, 2018 - 19:46 EST
This incident affected: Customer Service.