TC2000 was down for a few minutes due to an networking issue
Incident Report for TC2000
Resolved
This incident has been resolved.
Posted 2 months ago. Jan 10, 2019 - 13:34 EST
Monitoring
TC2000 was down for a few minutes due to an networking issue. The issue has been resolved and you can now login into TC2000 again. TC2000 Brokerage customers experiencing any issues with trading can use Trader Workstation or TWS mobile to access your trading account(s). We will continue to monitor this issue.
Posted 2 months ago. Jan 10, 2019 - 12:45 EST
This incident affected: Software, Market Data Feeds, Brokerage Services, Paper Trading (simulated), News Feeds, and Customer Service.