Trading is down in TC2000
Incident Report for TC2000
Resolved
This incident has been resolved.
Posted 3 months ago. Jan 24, 2019 - 10:31 EST
Investigating
We are currently experiencing an issue with trading in TC2000. TC2000 Brokerage clients can manage their accounts using TraderWorkstation, TWS mobile or by calling the trade desk at 203-618-4030.
Posted 3 months ago. Jan 24, 2019 - 09:45 EST
This incident affected: Brokerage Services.