Unable to place trade orders in TC2000 software
Incident Report for TC2000
Resolved
This incident has been resolved.
Posted Mar 16, 2017 - 10:01 EDT
Investigating
Engineers are working to identify the problem as quickly as possible. You can place orders through TWS, Web Trader in Account Management or by calling 1-203-618-4030.
Posted Mar 16, 2017 - 09:39 EDT