US Markets closed Monday, Jan 20th
Incident Report for TC2000
Resolved
This incident has been resolved.
Posted Jan 20, 2020 - 18:24 EST
Monitoring
US markets will be closed on Monday, January 20, 2020 in observance of Martin Luther King, Jr. Day. TC2000 and TC2000 Brokerage customer service departments will also be closed on this date. We will resume regular business hours on Tuesday, January 21st.
Posted Jan 17, 2020 - 08:37 EST