Positions are not updating in TC2000
Incident Report for TC2000
Resolved
This incident has been resolved.
Posted 11 months ago. Nov 23, 2018 - 10:35 EST
Investigating
Positions are not updating in TC2000. We are investigating this issue. Current positions are available in Trader Workstation, Trader Workstation mobile and account management.
Posted 11 months ago. Nov 23, 2018 - 09:56 EST
This incident affected: Brokerage Services.