Delayed option prices
Incident Report for TC2000
Resolved
This incident has been resolved.
Posted Feb 26, 2020 - 10:42 EST
Investigating
Some TC2000 customers are experiencing delays in option prices. We are investigating this issue.
Posted Feb 26, 2020 - 10:21 EST
This incident affected: Software and Market Data Feeds.