Customers having trouble logging into TC2000
Incident Report for TC2000
Resolved
This incident has been resolved.
Posted 2 months ago. Aug 08, 2019 - 11:01 EDT
Update
We are continuing to investigate this issue.
Posted 2 months ago. Aug 08, 2019 - 10:16 EDT
Update
We are continuing to investigate this issue.
Posted 2 months ago. Aug 08, 2019 - 10:13 EDT
Investigating
Some customers are reported problems logging into TC2000 this morning. We are investigating this issue.
Posted 2 months ago. Aug 08, 2019 - 10:13 EDT
This incident affected: Software, Market Data Feeds, Brokerage Services, and Paper Trading (simulated).