Dow Jones index feed is down
Incident Report for TC2000
Resolved
This incident has been resolved.
Posted 10 months ago. Dec 15, 2018 - 09:25 EST
Identified
We are not receiving quotes on the Dow Jones indexes this morning. We are working with our data provider to get this corrected.
Posted 10 months ago. Dec 13, 2018 - 09:41 EST
This incident affected: Market Data Feeds.