Problems Calling Customer Service
Incident Report for TC2000
Resolved
This incident has been resolved.
Posted 7 months ago. Nov 05, 2018 - 16:01 EST
Update
We are continuing to monitor for any further issues.
Posted 7 months ago. Nov 05, 2018 - 12:38 EST
Monitoring
Customers are having trouble reaching TC2000 and TC2000 Brokerage customer service via telephone. We are in contact with our phone provider who is working on a resolution. TC2000 customer service can be reached via email to support@TC2000.com and TC2000 Brokerage customer service can be reached by email to support@TC2000Brokerage.com.
Posted 7 months ago. Nov 05, 2018 - 12:37 EST
This incident affected: Customer Service.