Problem placing orders in paper and live trading accounts
Incident Report for TC2000
Resolved
This incident has been resolved.
Posted 14 days ago. Jan 04, 2019 - 11:16 EST
Investigating
We are experiencing an issue with placing order in both paper and live trading accounts. TC2000 Brokerage customers with live accounts can use TraderWorkstation or TWS mobile to place and manage orders until we get this issue resolved.
Posted 14 days ago. Jan 04, 2019 - 10:55 EST
This incident affected: Brokerage Services and Paper Trading (simulated).