Problem with Paper Trader in TC2000
Incident Report for TC2000
Resolved
Paper Trading in TC2000 is functioning normally.
Posted 13 days ago. Jul 06, 2018 - 10:22 EDT
Investigating
Paper Trading in TC2000 is current down. We are investigating the issue.
Posted 13 days ago. Jul 06, 2018 - 09:59 EDT
This incident affected: Paper Trading (simulated).