Some component lists are blank
Incident Report for TC2000
Resolved
This incident has been resolved.
Posted Jan 02, 2020 - 15:14 EST
Investigating
Some index and ETF component lists are blank right now and we are working to get this corrected.
Posted Jan 02, 2020 - 12:39 EST
This incident affected: Software.