Pre-market data is not available
Incident Report for TC2000
Resolved
This incident has been resolved.
Posted 19 days ago. Apr 01, 2019 - 08:26 EDT
Investigating
Pre-market data is currently not available in TC2000. We are working with our data provider to resolve the issue.
Posted 19 days ago. Apr 01, 2019 - 07:56 EDT
This incident affected: Market Data Feeds.