Unable to place trade orders in TC2000 software
Incident Report for TC2000
Resolved
Trading in TC2000 software has been resolved.
Posted Sep 20, 2016 - 17:35 EDT
Investigating
Engineers are working to identify the problem as quickly as possible. You can place orders through TWS or Web Trader.
Posted Sep 20, 2016 - 17:25 EDT