Investigating latency issues in TC2000
Incident Report for TC2000
Resolved
This incident has been resolved.
Posted 4 days ago. Aug 13, 2019 - 11:32 EDT
Update
We are continuing to investigate this issue.
Posted 4 days ago. Aug 13, 2019 - 10:30 EDT
Investigating
Latency issues are affecting some parts of the TC2000 software including trading order status updates. Orders are filling but there are delays in updating their status in TC2000. We are investigating this issue.
Posted 4 days ago. Aug 13, 2019 - 10:29 EDT
This incident affected: Software, Brokerage Services, and Paper Trading (simulated).